March 7th, 2022


I am still messy in how I use OpenBSD.

I still run snapshot a.k.a current system version, but while for many (library) dependencies from filesets I need to sysupgrade so I'm rather up to date with these, I usually just install the needed packages with just the big-U flag of pkg_add, so many packages stay out-of-date because i rarely take time to do the small-"u" upgrade of everything.

And I'm still a mess when it comes to dependencies of stuff that's only in portstree — I either read the description files manually and run a pkg_add, or I let it compile some of the dependencies from the portstree instead of gettng binary packages until there occurs something big enough and sure enough to be in binary packages then i interrupt the port building and install the dependency with pkg_add.

And thus I often resign from for example installing X11 apps because of a libX11 mismatch.

Also I do upgrading packages from portstree even less often… like, my `.xsession-errors` constantly gets

st:/usr/X11R6/lib/libX11.so.18.0: /usr/X11R6/lib/libX11.so.17.1 : WARNING: symbol(_XkeyTable) size mismatch, relink your program

and i see there's even

FvwmIconMan: FvwmIconMan*sort option no longer takes true or false value
Please read the latest manpage
FvwmIconMan: Bad element in show/dontshow list: name
xbatt:/usr/X11R6/lib/libX11.so.18.0: /usr/X11R6/lib/libX11.so.17.1 : WARNING: symbol(_XkeyTable) size mismatch, relink your program
Warning: Missing charsets in String to FontSet conversion
seamonkey:/usr/X11R6/lib/libX11.so.18.0: /usr/X11R6/lib/libX11.so.17.1 : WARNING: symbol(_XkeyTable) size mismatch, relink your program

and Seamonkey and xbatt are, IIRC, installed from binary packages which I though I had just updated. And haha I need to inspect my copied-from-examples fvwmrc.


OpenBSD misses things for me. I have no Visual Studio Code nor even Atom, I have to cope with Emacs. So no Github Copilot for me haha. It's not too easy to build ATS on it so I had to resign from learning the language at least while i'm away with this laptop.


Moreover, not finding FreeMind in the binary packages repository made me relearn Dotty editor from Graphviz.

Btw, annoying that "print graph to file" doesn't allow for "-Tsvg" and I have to do from command line.

Also, "save graph as" nor "load graph" don't "associate the .dot file" so "save file" and "reload" seem *not to do any action*.


But yeah, in several iterations of graphs I managed to write out my

/interests.gmi


I am also adding more stuff on my

https://wiki1.mikf.pl


I still fail to search packages with OpenBSD. I may have pkg_mklocatedb but that's not descriptions but just filenames. I only have `make search key=name` in portstree, and then I need to `pkg_info -Q name` for the same packages not to build from ports unnecessarily.


And it's no longer Kansas^W Nix, so I need to consider installing Python's and such packages with the likes of Pip, but so far I could resolve to finding them in the binary packages repository.


It's funny how because of Firefox being wrapped in OpenBSD's Pledge I need to move all the files I want to open with it into $HOME/Downloads. Like both if I want to open `file:///` html pages or pdfs, and if I want to upload a file to a website. Makes me use Seamonkey even more in the former case.


I need to improve on my workflow with publishing to my Gemini capsule on Flounder, as presently I am doing it by first committing with Git, then looking at the changes list, then using `pass -c flounder.online` to get the password in my clipboard for 45 seconds, and then running `sftp sftp://mkf@flounder.online:2024` (or even appending `/gemlog`) and pasting the password from clipboard, then running `put -r` for new directories and `put filename` for each file, `cd`ing into directories if needed.

I want to migrate my capsule to Sourcehut pages, but I need to make myself HTML generators as it doesn't have the HTML proxy out of the box like Flounder. Then I will be able to just have deployments just like in case of my Netlify websites, although git.sr.ht is a bit more limited by its ssh host key algorithms than Github, so it will be harder to make publishing from my PowerMac G5 running OS X 10.5.8 possible.


As I'm using tcsh, I miss having completions for `pass` password store, for Git, and some other stuff. Not sure if I shouldn't replace those with some more Unixey-or-something way. Or just purer, I don't want weird side-effects and delays on autocompletion. Maybe I just need to write specific programs for some of those.


Today I wanted to forget a WiFi network on this OpenBSD laptop. So I removed the "join" line with "wpakey" from /etc/hostname.iwn0 and I thought `doas sh /etc/netstart` will do. Turned out I still kept getting connected to it, and what I had to do turned out to be `doas ifconfig iwn0 -joinlist; doas sh /etc/netstart`.


It gives me a weird feel as all my Git diff commands run in a full-terminal less with the tildes to the bottom. I keep feeling as if maybe there is something to scroll up for. I need to change that.


I have been getting started with Common Lisp, did a writeup of an algorithms task implemented with lazy sequences done with no-macro lambda CDRs:

wiki1.mikf.pl: "Place k elements such that minimum distance is maximized"


So yeah, things.



/gemlog/